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TransCore’s AP4600 Multifunction Tag Programmer is a compact device used 
for reading and writing data to TransCore’s suite of toll, parking, access, and 
transportation tags, including eGo® and eGo Plus tags formatted for ATA, Wiegand, 
and Title 21.

Purpose of This Guide
This user guide is intended for skilled personnel (including technicians and engineers) to provide 
information for setting up and using the AP4600 Multifunction Tag Programmer. This guide describes the 
steps to import the required license certificate to a host computer system. It also shows how to program 
and read tags with the programmer and explains how to create and use batch files. 
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WARNING TO USERS IN THE UNITED STATES

FCC RADIO FREQUENCY INTERFERENCE STATEMENT

47 CFR §15.105(A)

NOTE: This equipment has been tested and found to comply with the limits for a Class A digital 
device pursuant to Part 15 of the FCC rules. These limits are designed to provide reasonable 
protection against harmful interference when the equipment is operated in a commercial 
environment. This equipment generates, uses, and can radiate radio frequency (RF) energy and 
may cause harmful interference to radio communications if not installed and used in accordance 
with the instruction manual. Operating this equipment in a residential area is likely to cause harmful 
interference, in which case, depending on the regulations in effect, the users may be required to 
correct the interference at their own expense.

NO UNAUTHORIZED MODIFICATIONS

47 CFR §15.21

CAUTION: This equipment may not be modified, altered, or changed in any way without 
permission from TransCore LP. Unauthorized modification may void the equipment 
authorization from the FCC and will void the TransCore warranty.

TRANSCORE, LP

USA
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Chapter  1  Setting Up the AP4600 Programmer

Required Supplies
You need the following additional materials and/or tools to complete the programmer and license 
certificate installation:

•	 Host PC using Windows® operating system with at least one USB port

•	 USB flash drive with field configuration software provided with tag programmer

•	 USB data cable provided with tag programmer

•	 Power adapter with power cable provided with tag programmer

•	 Tags for programming

•	 License certificate (provided by TransCore Order Administration via e-mail)

Install the Tag Programmer Host Software
Note: You must have administrative privileges on your PC to install this software. Contact your IT 
department for assistance.  

1.	 Insert the USB flash drive with the field configuration software into the USB port on the host 
computer.

2.	 Access the USB flash drive to find the user instructions and the USTP Installer files.

3.	 Double click on the installer file. Follow the on-screen prompts to load the AP4600 
Multifunction Tag Programmer host software to the computer desktop.

CAUTION:
Do not start the host software program until you are prompted to do so.

Set Up the Tag Programmer
Note: The AP4600 programmer is designed to be used in an office environment.

1.	 Place the tag programmer on a flat surface. Figure  1 shows the ports on the rear panel of the 
programmer.

2.	 Connect the USB data cable from the port at the rear of the programmer to one of the host 
computer’s USB ports.

3.	 Insert the power plug from the power adapter to the power supply port at the rear of the 
programmer. Plug the power cord into a standard 120V AC wall outlet.

4.	 Toggle the power switch to the ON position.

Setting Up the AP4600 Programmer
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Install the USTP Hardware Driver
Note: This section shows general guidelines for installation from a computer running Windows 7. 
You may find these steps are slightly different depending on your operating system.

1.	 When you power on the AP4600 Programmer, a prompt should appear on the host computer 
screen (Figure  2). Click BROWSE and follow the on-screen instructions to install the new USTP 
hardware device driver. 

Note: The driver file is located in C:\TransCore\USTP\Drivers, unless a different location was 
selected when the host software was installed.  

2.	 If a prompt does not appear, the driver may already be installed on the computer. Proceed to  
“Import the AP4600 License Certificate” on page 3.

Figure 1 Ports on Rear Panel of AP4600 Tag Programmer

Figure 2 Prompt to Install Device Driver

AP4600 Programmer User Guide
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Import the AP4600 License Certificate
1.	 You will receive an email from TransCore with the license certificate file attachment. Save this 

file to a folder that you can easily locate on the computer, such as the desktop.

Note: Save the e-mail with the original attachment for future reference. 

2.	 Ensure that the license certificate filename matches the 5th through 12th digits of the 
programmer control number. To locate the programmer control number, first ensure that the 
AP4600 is connected to the computer and powered on.

3.	 Start the AP4600 host software application by double-clicking on the USTP icon on your 
desktop.

Note: If a prompt appears saying “COULD NOT OPEN READER”, return to the section “Install the 
USTP Hardware Driver” on page 2 and contact your IT Department for assistance to install the 
driver manually; then return to Step 4 in this section.  

4.	 When the application window opens, click Help, then select About. The About USTP screen 
displays the firmware and hardware versions of the AP4600 programmer, as well as the 
programmer control number. Figure  3 highlights the portion of the control number you will 
need in order to verify the license certificate file.

5.	 Close the About USTP window after you have verified that the license certificate filename 
matches the indicated portion of the programmer control number.

6.	 In the main window, click File, select Import, and then select License File. Browse to select the 
license certificate file that you saved at the beginning of the process (refer to “Install the USTP 
Hardware Driver” on page 2.) This will become the current active license file. If an updated 
license file is subsequently received, a repetition of this same process will ensure that the host 
is working with the latest license file.

CAUTION:
If the license certificate does not match the 5th through 12th digits of the AP4600 tag 
programmer control number, you will not be able to program tags. Contact your TransCore 
sales representative if you need assistance in getting a valid license certificate. 

Figure 3 About USTP Screen
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Start the AP4600 Host Software Application
Start the host software application by double-clicking the USTP icon on your desktop. This step activates 
the license certificate internal check and configures the programmer to your specific licensing and 
permissions data. 

If the license file status indicator does not show OK, this indicates a problem with the license file 
(Figure  4). Recheck the license file control number, and try importing the license file again.

If the license file status folder shows OK (Figure  5), the license file has been successfully validated and 
you are ready to program tags.

Figure 4 Status Indicator Showing License File is Invalid

Figure 5 Status Indicator Showing License File is Valid
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Chapter  2   Host Software Application

Use the AP4600 Host Software Application
The AP4600 host software has four views:

1.	 USTP View

2.	 Title 21 View

3.	 Extended Data View

4.	 Rail View

Each view is used for specific data formats and supports specific tag models, and may have additional 
features. All views have:

•	 Attenuation controls

•	 Read buttons

•	 Write buttons

•	 Tag data display area

•	 Optional area to display status messages

To switch between views, use the View menu. To switch tag models, use the Model menu. If a tag model 
is selected that is not supported in the current view, the interface automatically switches to a supported 
view.

USTP View
The USTP View (Figure  6) is used to read and write raw hex data, 6-bit ASCII data, or Wiegand data from 
and to SeGo and eGo tags, and to read the same data from ATA tags. A Single Page format is available to 
read and write raw hex data to and from non-ATA data pages. The USTP View supports batch operation, 
and logging data to a file.

 Host Software Application
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Title 21 View
The Title 21 View (Figure  7) is used to read and ack Title 21 tags.

Figure 6 USTP View

Figure 7 Title 21 View
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Extended Data View
The Extended Data View (Figure  8) is used to read and write raw hex data to arbitrary sets of single 
non-ATA data pages. Data pages can be individually selected in any combination for each operation. 
Operations are performed in sequence for selected pages. An error will abort all remaining page 
operations.

Some tags may not support reading or writing to certain pages and will always “error out” on those pages. 
These pages must be deselected for operations on these tags.

Figure 8 Extended Data View

 Host Software Application
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Rail View
The Rail View (Figure  9) is used to read and write AAR data and 6-bit ASCII data to and from SeGo 
tags, and to read the same data from ATA tags. Only railcar data can be written. Writes only support AES 
encryption unless the license file and the radio model both support AAR encryption.

Figure 9 Rail View

AP4600 Programmer User Guide

TransCore Proprietary 8



Chapter  3  Getting Tag Data

Positioning Tags on the AP4600 Programmer

Read Data from a Tag
Most tags should be placed driver side up in the center of the tag programmer target area.

CAUTION:
Proper placement on the programmer is critical when programming sticker and hang tags. 
Be sure to orient the tag between the polarization axis lines. For best results, gently press the 
sticker tags flat against the surface of the programmer with your hand.

Hang Tags

 Figure  10 shows the correct placement and orientation of a hang tag.

Figure 10 Hang Tag Placement on Programmer Target Area

Getting Tag Data
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Windshield Sticker Tags

Figure  11 shows similar placement and orientation for a windshield sticker tag.

Hard Case Tags

Hard case tags are placed face up and centered on the programmer target area as shown in 
Figure  12.

Figure 11 Windshield Sticker Tag Placement on Programmer Target Area

Figure 12 Hard Case Toll Tag Placement on Programmer Target Area

AP4600 Programmer User Guide
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Intermodal Tags

Intermodal tags should be placed face down, as shown in Figure  13.

AT5417/AT5419 Externally Powered Signal Tag
1.	 The AT5417/AT5419 Signal Tag requires a custom programming bracket and external power in 

order to program the tag.

2.	 Position the programming bracket on top of the AP4600 Tag Programmer.

3.	 Place the signal tag face up on the bracket. Align the tag by placing the twisted pair interface 
cable into the notch on the bracket (Figure  14). The tag can be oriented in either direction.

Figure 13 Transportation Tag Placement on Programmer Target Area

Figure 14 Placement of AT5417/AT5419 on Programming Bracket

Getting Tag Data
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Note: The programming bracket can be permanently attached to the AP4600 Programmer with four 
6-32, 1.5” long machine screws (not included).

4.	 Apply external power to the tag. Refer to the AT5417/AT5419 Externally Powered Signal Tag 
Installation Guidelines for details on power requirements.

Reading and Writing Tag Data

Reading Data from a Tag
CAUTION: 
Be sure there is only one tag at a time within the read range. Multiple tags in the range area 
may cause the read to fail.

Perform the following steps to read data from a tag:

1.	 Select the correct tag model from the Model menu.

Note: Only tags of the selected model will be detected.

2.	 Select the desired view from the View menu. Be sure the selected view supports the selected 
tag model.

3.	 Configure the view appropriately. For example, select the correct tag data format in the USTP 
View, or select the desired pages in the Extended Data View.

4.	 Position the tag on the AP4600. Adjust the attenuation if necessary.

5.	 Press the Read button or the F1 hot key.

6.	 The results of the read operation are displayed.

a.	 If the read was successful, the tag data appears in the appropriate boxes.

b.	 If the read failed, a status message appears in one or more boxes including the Status 
Message box (unless Status Messages were deselected in the Options Menu).

c.	 If the Operation Status area is present, it will indicate the operation status with green for 
success, red for failure, and yellow or gray for other conditions.

If SeGo, eGo, or ATA data is successfully read, the tag ID and/or raw hex data will always be 
displayed. 

If the read was successful but the data cannot be processed by the current view or selected 
format (for example, if a Wiegand data format is selected in the USTP View but the tag does not 
contain Wiegand data, or if the tag contains an unsupported AAR data type in the Rail View), no 
other data will be shown and a message will be shown in the Status Message box.

Examples of successful reads are shown in Figure  15, Figure  16, Figure  17, and Figure  18.

AP4600 Programmer User Guide
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Figure 15  Successful ATA read of hex data in USTP View

Figure 16 Successful Title 21 read in Title 21 View
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Figure 17 Successful SeGo read of hex data in Extended Data View

Figure 18 Successful SeGo read of AAR data in Rail View
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Writing Data to a Tag 
CAUTION: 
Be sure there is only one tag at a time within the read range. Multiple tags in the range area 
may cause the write to fail.

Perform the following steps to write data to a tag:

1.	 Select the correct tag model from the Model menu.

Note: Only tags of the selected model will be successfully programmed.

2.	 Select the desired view from the View menu. Be sure the selected view supports the selected 
tag model.

3.	 Configure the view appropriately. For example, select the correct tag data format in the USTP 
View, or select the desired pages in the Extended Data View.

4.	 Enter the desired data in the appropriate data box(es).

a.	 Only data boxes appropriate to the selected data format will accept input. All others will 
be disabled (“grayed-out”).

b.	 Incorrect data (for example non-hex data in a hex data box, or a Wiegand Card ID value 
that is too high) will either be disallowed by the interface or will cause the write to fail.

c.	 Missing data values (for example hex characters after the fifth if only five are entered) are 
interpreted as zeroes.

5.	 Position the tag on the AP4600. Adjust the attenuation if necessary.

6.	 Press the Write button or the F2 hot key.

7.	 The results of the write operation are displayed.

a.	 If the write failed, a status message appears in one or more boxes including the Status 
Message box (unless Status Messages were deselected in the Options Menu).

b.	 If the Operation Status area is present, it will indicate the operation status with green for 
success, red for failure, and yellow or gray for other conditions.

If SeGo or eGo data is successfully written, the tag is re-read and the data displayed.

An example of a successful write is shown in Figure  19. 

Getting Tag Data
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Downgrading Tags
The E1R USTP host application has the ability to downgrade fullframe tags to halfframe tags when writing data. 
Perform the following steps to use this feature:

1.	 Select Downgrade Tags from the Options menu as shown in Figure  20.

2.	 A confirmation prompt will appear. Select OK if tags should really be downgraded.

Figure 19 Successful SeGo write of Wiegand data in USTP View

Figure 20 Selecting Downgrade Tags menu option
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CAUTION: 
Once a fullframe tag has been changed to a halfframe tag, it cannot be changed back.

3.	 When Downgrade Tags is enabled, the Write buttons are changed as shown in Figure  21.

4.	 While Downgrade Tags is enabled, writing data to a fullframe tag irrevocably changes the tag 
to halfframe.

Using Batch Files

Creating a Batch File
Batch files must be comma (,) delimited plain text with one data record per line.

Each data record must begin with a Tag Data Format identifier from Table  1. This identifier indicates the 
Tag Data Format for the rest of the records.

Table 1 Tag Data Format Identifiers

Tag Data Format Identifiers

0 Wiegand 26-Bit
1 Wiegand 34-Bit
2 CardKey 34-Bit
3 McGann 37-Bit

Figure 21 Write Buttons when Downgrade Tags is Enabled

Getting Tag Data
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Table 1 Tag Data Format Identifiers

Tag Data Format Identifiers

4 LSU 32-Bit 
5 HID 35-Bit
6 U.M. 37-Bit
7 ASCII (ATA Halfframe)
8 ASCII (ATA Fullframe)
9 Hex (ATA Halfframe)
10 Hex (ATA Fullframe)
11 Hex (Single Page)

Data records for each of the Wiegand tag data format identifiers should be followed by comma-separated 
values for facility and ID fields. For example:

0,255,0001

0,255,0002

0,255,0003

ASCII (ATA Halfframe) tag data format identifiers should be followed by 10 ASCII characters from the 6-bit 
ASCII character set. For example:

7,ABCDEFGHIX

7,ABCDEFGHIY

7,ABCDEFGHIZ

ASCII (ATA Fullframe) tag data format identifiers should be followed by 20 ASCII characters from the 6-bit 
ASCII character set. For example:

8,ABCDEFGHIJKLMNOPQRSX

8,ABCDEFGHIJKLMNOPQRSY

8,ABCDEFGHIJKLMNOPQRSZ

Hex (ATA Halfframe) tag data format identifiers should be followed by 15 HEX characters from the 
hexadecimal character set. For example:

9,ABCDE0123456781

9,ABCDE0123456782

9,ABCDE0123456783

Hex (ATA Fullframe) tag data format identifiers should be followed by 30 HEX characters from the 
hexadecimal character set. For example:

AP4600 Programmer User Guide
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10,ABCDE01234567890123456789ABCD1

10,ABCDE01234567890123456789ABCD2

10,ABCDE01234567890123456789ABCD3

Raw Hex Data tag data format identifiers should be followed by a field for the number of the page to be 
written, followed by a data field of 16 Hex characters. For example, for a Write to Page 4:

11,4,1234567890ABCDE1

11,4,1234567890ABCDE2

11,4,1234567890ABCDE3

Using a Batch File
After creating the batch file, start Batch Programming by selecting File, then Open, and Batch File from the 
menu (Figure  22).

The hot keys F1 (Read), F2 (Write), and F3 (Next Record) can be used for batch processing control.

When processing batch files, the Tag Data Format does not need to be selected on the screen. The host 
will detect the data format type and change the display accordingly. The name of the batch file will be 
shown along the bottom center of the display. A numeric pointer showing which record is currently loaded 
will be shown.

Perform the following steps to process the batch file:

1.	 Press the Read button or F1. Data from the tag will appear in the data boxes.

2.	 Press the Next button or F3. Data from the batch file will appear in the data boxes.

3.	 Press the Write button or F2.

If for some reason the host does not write the tag, indicated by a Program Status red mark next to the Tag 

Figure 22 Opening a Batch File Menu
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Data Write field, the write can be attempted again by pressing the Write button. The data for the current 
write will not be changed until the NEXT button is pressed, allowing for multiple write attempts.

When the end of the batch file is reached, a warning notice will be given, and the NEXT button will 
disappear (Figure  23).

Data Logs
Data that is read-from and written-to tags can be logged to standard CSV (Comma Separated Value) files.

Logging Tag Read Data
To enable logging of data read from tags, perform the following steps:

1.	 Select Open from the File menu and click on Read Log as shown in Figure  24.

Figure 23 End of Batch File Message
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2.	 Choose the desired file name and location from the file dialog.

3.	 An active read log is displayed in the status area as shown in Figure  25.

4.	 Any data successfully read from tags while the read log is active will be written to the selected 
file in the format described in the section “Data Log Format” on page 22. To close the log, 
select Close from the File menu and click on Read Log.

Figure  25  Read Log Status

Figure  24  Opening a Read Log from the Menu 
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Logging Tag Write Data
To enable logging of data written to tags, perform the following steps:

1.	 Select Open from the File menu and click on Write Log. Refer to Figure  24.

2.	 Choose the desired file name and location from the file dialog.

3.	 An active write log is displayed in the status area. Refer to Figure  25.

4.	 Any data successfully written to tags while the read log is active will be written to the selected 
file in the format described in the section, “Data Log Format” on page 22.

5.	 To close the log, select Close from the File menu and click on Write Log.

Data Log Format
Logged data is written in a standard CSV format, with one or more data fields on a line for each record. 
The data fields are separated by commas. Read data and write data use the same format, with the fields 
described in Table  2.

Table 2 Log Data Fields

Date Time Record # Protocol Data Format Decoded 
Tag Data

Raw Tag 
Data

YYMMDD HHMMSS 1 – XXXX Refer to 
Protocol 
Field

Refer to Data 
Format field

Refer to 
Decoded Tag 
Data field

Refer to Raw 
Tag Data 
field

Date field: The two-digit calendar year, month, and day that the record was created, in local time.

Time field: The two-digit hour, minute, and second that the record was created, in local 24-hour time.

Record # field: The number of each record in the data file, starting at 1 for the first record in each file and 
incrementing for each record.

Protocol field: One of the values shown in Table  3, corresponding to the tag model of the tag that created 
the record.

Table 3 Protocol Field

Value Tag Model
ego eGo
sego SeGo
ata ATA
T21 Title21
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Data Format field: One of the values shown in Table  4, corresponding to the data format selected when 
the record was created.

Table 4 Data Format Field

Value Data Format
wg26 USTP View, Wiegand 26-Bit

wg34 USTP View, Wiegand 34-Bit

cardk USTP View, CardKey 34-Bit

mcg37 USTP View, McGann 37-Bit

lsu32 USTP View, LSU 32-Bit

hid35 USTP View, HID 35-Bit

mm37 USTP View, U.M. 37-Bit

ata10 USTP View, ASCII (ATA Halfframe)

ata20 USTP View, ASCII (ATA Fullframe)

hex USTP View, Hex (ATA Halfframe) or Hex 
(ATA Fullframe)

raw USTP View, Hex (Single Page)

t21 Title21 View

0xFF (FF is the byte address in hex) Extended Data View

aar Rail View

Decoded Tag Data field: A string containing the tag data decoded according to the selected format, or a 
blank string if the selected format does not indicate decoded data.

Raw Tag Data field: The raw hex data read from or written-to the tag.

A sample data record is shown in Figure  26.

Figure  26  Sample Data Log
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Chapter  4  Printing and Troubleshooting

Optional Customer-Supplied Equipment
If you are applying printed labels to tags, TransCore has approved the following printer and label size:

•	 Brother QL-500 series label printer

•	 15/16” x 3 1/2” labels

Selecting the Print Labels Option

Printing a label for each tag
Select Options then Print Labels from the menu (Figure  27). The approved label printer is a Brother QL-
500 series printer.

Use standard 15/16-inch tall by 3 1/2-inch wide label forms in the printer. Selecting Print Labels prints the data 
field information of the current programmed tag onto a label. The label prints after the tag is successfully 
programmed.

Note: If you select Print Labels when no printer is attached to the PC, the host program switches off 
the Print Labels function. Reconnect printer and select Print Labels again.

Note: Before printing labels, configure the printer for landscape orientation printing using the Printer 
Setup screen or at Start>Settings>Printers and Faxes from the Windows Start menu. The host 
software does not set the label orientation.

Note: Use Print Hex Data from the Options menu to control whether the Hex Data line is printed. 

Figure 27 Selecting Print Labels
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If you have selected Print Labels, a label prints when the tag is programmed. Affix this label to the tag.

Helpful Information
The AP4600 Tag Programmer reads from and writes to tags having the Super eGo (SeGo), and eGo tag 
protocols, and reads from Title 21/Allegro and ATA tag protocols. 

The software reads from and writes to tags having the following tag data formats: 

•	 Wiegand 26-Bit

•	 Wiegand 34-Bit

•	 CardKey 34-Bit

•	 McGann 37-Bit

•	 LSU 32-Bit

•	 HID 35-Bit

•	 U.M. 37-Bit

•	 6-bit ASCII

•	 Raw hex

•	 AAR (S-918)

Functions and Features
The AP4600 Tag Programmer Host Software provides the following helpful functions and features:

•	 Read and write success and failure are indicated by visual and audible cues

•	 Built-in tag log file output function (See Help feature in host software for more information)

•	 Built-in batch programming function

•	 Label printing supported using a Brother QL-500 series printer and 15/16” x 3 1/2” labels

The current settings (tag model, view, data format, etc) are retained and used the next time the software 
starts.

Diagnosing System Problems
Should you encounter trouble when using the AP4600 Tag Programmer, perform the following diagnostic 
steps:

1.	 Reposition the tag on the target area and try reading again.

2.	 If Step 1 does not correct the problem, close the host software, cycle power to the programmer 
by toggling the power switch, and re-open the host software.

3.	 If Steps 1 and 2 do not correct the problem, contact TransCore Technical Support for further 
assistance.
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For more information:
 
Sales Support 
800.923.4824 

Technical Support 
505.856.8007
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